0

Export Gedcom File (AGS) Ancestris Genealogy Software

Introduction

Ancestris is entirely free for Windows, Mac, and Linux. Visit the Ancestris website for details.

It offers one of the most complete GEDCOM implementations for both the GEDCOM Standard Release 5.5 and 5.5.1 specifications.

See the Migration Guide for migrating the exported GEDCOM into any Ancestris version.

Most Multimedia Conversion modes are supported.

The Character Set Encoding option defaults to UTF-8 but works for UTF-16 & ANSI and all Unicode characters are supported.

The [[private]] Text Option defaults to Include private text but remove the [[ ]].

The Rich Text Formatting defaults to Remove rich text codes leaving just plain text.

See both the (AGS+) Full Data Export Details and (AGS-) Brief Data Export Details below.

Migration Guide
Installation Process

The download & installation of the Ancestris Daily Version is straightforward.
The How To Install… Ancestris Installation page has Java prerequisite advice. Follow the Installation on Windows step-by-step guide.

Import GEDCOM File

From the Welcome > My Ancestris tab, or File menu, or toolbar, use Open a genealogy and choose the FH Plugin Export folder and the Project…AGS UTF8.ged file to import.
In the Open GEDCOM dialogue choose Do not convert to import the file unchanged, but choose Convert to create an Ancestris copy in the same folder with any errors corrected.

Use Tools > Gedcom > Validation of data and Gedcom format to obtain a validation report.

Preferences & Views

The Tools > Preferences > Editing tab allows a Default editor to be chosen.
The Aries editor is most like the FH Property Box. The Gedcom editor is like the FH All tab.

The Tools > Preferences > Extensions > Validation tab Places not matching format in header are valid inhibits warnings about the number of jurisdictions comma-separated place parts.

Use View > Entities table to obtain a display like the FH Records Window.

Use View > Dynamic tree to obtain a display like the FH Ancestor and Descendant Diagram.

Use View > Cygnus/Gedcom/Aries editor to display any record.

Use View > Table of places to obtain a display like the FH Tools > Work with Data > Places.

(AGS+) Full Data Export Details

All the (Str+) Full Data Standard GEDCOM Release 5.5.1 rules apply except as defined below.

Header Record (HEAD)

★ Other Tags (COPR, FILE, _VAR, _UID, _USED, _PCIT)
These tag lines are all removed entirely.

★ Destination & Place Hierarchy (DEST, PLAC, FORM)
The header line 1 DEST ANY is inserted.
The header line 1 PLAC is inserted followed by 2 FORM jur1, jur2, jur3 etc, depending on the maximum Place part jurisdictions found.

(AGS-) Brief Data Export Details

All the (Str-) Brief Data Standard GEDCOM Release 5.5.1 rules apply together with the (AGS+) Full Data Export Details defined above.

Return to the GEDCOM Export Mode advice help page.

Return to the Export Gedcom File main help page.


Plugin Export Gedcom File

Help content on this page is owned and provided by Mike Tate, the plugin's author, Calico Pie takes no responsibility for its content.